Outage Notice District Circuit - RCOE Riverside to Coachella Valley USD
Resolved
This incident has been resolved.
Posted Apr 14, 2024 - 00:42 PDT
Investigating
Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted Apr 13, 2024 - 09:09 PDT
This incident affected: District Connections (Coachella Valley USD via Riv F).