Outage Notice District Circuit - RCOE Calhoun Indio to Moreno Valley USD
Resolved
This incident has been resolved.
Posted Apr 14, 2024 - 01:01 PDT
Investigating
Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted Apr 13, 2024 - 09:09 PDT
This incident affected: District Connections (Moreno Valley USD via Ind F).