Outage Notice District Circuit - RCOE Indio to Nuview Union SD

Resolved

This incident has been resolved.
Posted 13 days ago. Mar 23, 2025 - 00:59 PDT

Investigating

Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted 13 days ago. Mar 23, 2025 - 00:45 PDT
This incident affected: District Connections (Nuview Union SD via Ind S).