Outage Notice District Circuit - RCOE Riverside to Perris Elementary SD

Resolved

This incident has been resolved.
Posted May 23, 2025 - 21:14 PDT

Investigating

Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted May 23, 2025 - 20:25 PDT
This incident affected: District Connections (Perris Elementary SD via Riv CC).