Outage Notice District Circuit - RCOE Indio to Nuview Union SD
Resolved
This incident has been resolved.
Posted Oct 14, 2024 - 03:05 PDT
Investigating
Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted Oct 13, 2024 - 11:08 PDT
This incident affected: District Connections (Nuview Union SD via Ind S).