Outage Notice District Circuit - RCOE Sky Canyon Murrieta to Perris Elementary SD
Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 00:58 PDT
Investigating
Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted Mar 29, 2024 - 00:12 PDT
This incident affected: District Connections (Perris Elementary SD via Mur S).