Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2026 - 07:00 PDT
Scheduled
Our RCOE Indio location will be undergoing electrical and power maintenance to improve and maintain critical infrastructure and services in the desert region. District service (Internet/FaaS/VMaaS/BaaS) will continue to operate primarily out of Riverside during this time, but will remain degraded and unavailable locally at our Indio Data Center during this maintenance window.
For any additional information or questions, please open a support request at https://itsupport.rcoe.us/
Posted Jul 16, 2026 - 16:26 PDT
This scheduled maintenance affected: RCOE Hosted Services (Firewall aaS - Indio, Backup aaS - Indio, Virtualization aaS - Indio), RivCore (Indio Network Services, Ind K12HSN uplink to CSSBPD), and District Connections (Beaumont USD via Ind F, Coachella Valley USD via Ind S, Desert Sands USD via Ind S, Moreno Valley USD via Ind F, Nuview Union SD via Ind S, Palm Springs USD via Ind F, Palo Verde USD via Ind F, Perris Union HSD via Ind S, Riverside USD via Ind XC, Romoland SD via Ind S, San Jacinto USD via Ind S).