Outage Notice District Circuit - RCOE Riverside to Beaumont USD
Resolved
This incident has been resolved.
Posted Mar 14, 2024 - 16:28 PDT
Investigating
Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted Mar 14, 2024 - 09:51 PDT
This incident affected: District Connections (Beaumont USD via Riv S).