Outage Notice District Circuit - RCOE Indio to Nuview Union SD

Resolved

This incident has been resolved.
Posted 3 days ago. Mar 31, 2025 - 16:35 PDT

Investigating

Status: Down - This is an automated alert generated from monitoring. The relevant technical team(s) have been notified and will provide updates to this notice as appropriate.
Posted 3 days ago. Mar 31, 2025 - 16:25 PDT
This incident affected: District Connections (Nuview Union SD via Ind S).